MrAntiFun + WeMod Partnership Announcement

game

Kalas

Honorary Member
Master Donor
Joined
Jun 5, 2014
Messages
2,836
Reaction score
933
hi i download far cry 4 and it said i needed an i5cpu to run i got a intel 2 quad core q8200 at 2.33 and its leting me play the game whats up with that

You can play the game what do you want more then that >?
 
Top