MrAntiFun + WeMod Partnership Announcement

I would have three requests: Assassin'Creed Unity ,Tropico 5 and The Witcher Wild Hunt

yadira69

Super Donor
Joined
May 10, 2015
Messages
161
Reaction score
43
I wanted to thank you for the great work you are doing and also to all the people who help in the forum.
I would have three requests:
1: There are problems with the version of the trainer 1.4 Assassin 'Creed Unity, because they did update Uplay and does not work with this version. I tried to prove it is not working.
2: Error in the version of Tropico 5 Trainer 1.8, even here they did upgrade to 9.1 in the Kalypso Launcher
3: Problems but not so serious in the trainer version 1.3 The Witcher Wild Hunt
Sorry for my English, I speak Spanish and Italian (I am using Google translator)
Thank you
 
Top